quarta-feira, 18 de abril de 2012

AutoStart/Autoboot VM Citrix XenServer 6!

Boa tarde Galera,

Para aqueles que já são adeptos da virtualização isso não deve ser novidade, mas para os demais.
Nós usuários do virtualizador XenServer distribuído gratuitamente pela empresa Citrix, nos deparamos com um problema a partir da versão 6. Nesta versão o recurso de autoboot/autostart que era responsável por iniciar as vm's automaticamente durante o boot do servidor não está mais disponível. A justificativa dada pela Citrix para desativar a opção foi referente a problemas com HA.
Porém linux é linux :D abaixo segue um tutorial de como realizar o procedimento em modo texto!

1) Habilitando Ligamento Automático;
Execute o comando abaixo para pegar o uuid do pool:


# xe pool-list


O comando acima deverá retornar algo como:


uuid ( RO)  : 3cc48f57-4a72-1368-ca71-366c7183989


Agora para ativar a inicialização automática execute o comando abaixo incluindo o uuid recebido acima:

xe pool-param-set uuid=3cc3455-3a4f-1235-ca12-334c4455678 other-config:auto_poweron=true


2) Agora vamos escolher quais vm's serão iniciadas:
Neste procedimento também será necessário capturar o uuid de cada vm, para isso utilize o comando:


# xe vm-list


O comando acima deverá retornar algo como:



uuid ( RO)           : 78a934f3-20e5-a4341b-0403-5aa4e3726467
name-label ( RW): NOME_DA_VM
power-state ( RO): running


Como no item 1 capture o uuid da vm e utilize-o no comando abaixo:

xe vm-param-set uuid=78a934f3-20e5-a4341b-0403-5aa4e3726467 other-config:auto_poweron=true

Pronto! Agora basta reiniciar e testar!






9 comentários:

Byte Work Informática disse...

Boa tarde Rodrigo, tentei realizar o procedimento que você indica no XenServer 6.0.2 mas continua não inicializando a VM automaticamente, tem mais algum comando?

Eduardo Leal disse...

Voce tem que colocar na inicializacao e reiniciar, senao realmente nao funciona!!!

Gustavo Luiz disse...

Rodrigo, parabéns! Funciona corretamente!

Abraço

Tiago francisco andrade diocesano disse...

Muito obrigado, você salvou a minha vida! Valeu por postar o tutorial simples, fácil e eficiente. ;)

Alipio Secundino disse...

muito bom amigo me ajudou muito!!!

Luiz Henrique disse...

Obrigado amigo, tutorial muito útil...

Anônimo disse...

Ok, funciona muito bem. Obrigado!

Pauloliveira disse...

Perfeito..
Funcionou 100%..

Obrigado por compartilhar..

Anônimo disse...

a inicializacao é no etc/rc.local ???